Some users may experience an error upon accessing their Canva designs

Incident Report for Canva可画

Resolved

Some users are experiencing problems accessing Canva designs. We have identified the cause and are working to correct it.
Posted Mar 04, 2026 - 17:29 CST

Investigating

Some users are experiencing problems accessing Canva designs. We have identified the cause and are working to correct it.
Posted Mar 04, 2026 - 17:28 CST